What's new
Versions
  1. 1.18
Required Dependencies
Optifine is not required but there is a version for op users
What is this pack contains.

1-set of armor .

2-items(axe/shield).

3-confing for optifine and vannila.

4-guide/tutorial with the commands and intrutions on how to get the items.

aslo if you have any requests or sugestions feel free to dm-me on my discord(Fritz#7564).
  • norse12.png
    norse12.png
    538.8 KB · Views: 79
  • d11.png
    d11.png
    689.8 KB · Views: 79
  • display2.png
    display2.png
    499.7 KB · Views: 84
Author
FritzAngelos
Downloads
1
Type
Digital product
License Duration
Unlimited
Price
7.00 USD
Views
543
First release
Last update
Rating
0.00 star(s) 0 ratings

More resources from FritzAngelos

Top