What's new

Using custom models?

PsychoLynx

New Member
Premium Supporter
Supporter
Joined
Jul 2, 2016
Messages
25
Hi!

Is there currently any way to make a mob use a custom model from a resouce pack? Thanks!
 
Last edited:

Narrator

Member
Joined
Dec 19, 2016
Messages
34
First, you have to create the custom item. Set your item flags to unbreakable, then set the data of your item to the damage variant you want to use. So, for example, a diamond sword;

CustomSword:
Id: diamond_sword
Data: 1

Then simply set the "CustomSword" as the equipment in the main hand of whichever mob you want to hold it.

Unless of course you mean a custom model for the mob itself, which isn't possible.
 

PsychoLynx

New Member
Premium Supporter
Supporter
Joined
Jul 2, 2016
Messages
25
Yeah, I meant a custom model for the mob itself, or at least a skin (trying to reskin a chicken).
 

Ugikie

Member
Joined
Jan 20, 2017
Messages
74
First, you have to create the custom item. Set your item flags to unbreakable, then set the data of your item to the damage variant you want to use. So, for example, a diamond sword;

CustomSword:
Id: diamond_sword
Data: 1

Then simply set the "CustomSword" as the equipment in the main hand of whichever mob you want to hold it.

Unless of course you mean a custom model for the mob itself, which isn't possible.
Would there be a way with the new condition system to make these items only usable by a certain class in Heroes? @Kainzo
 

Robotnikman

Member
Premium Supporter
Supporter
Joined
Mar 30, 2017
Messages
95
I am having trouble with using custom models for items. I added a model for a gun to a stone hoe, and when I spawn a zombie mob with the item it just shows the stone hoe instead of the weapon model. I know its set up right since crackshot can show the model just fine

heres how the item is set up

Code:
ZombieBazooka:
  Id: 291
  Data: 9
  Unbreakable: true
  Hides:
  - ATTRIBUTES
  - ENCHANTS
  Display: '&2M1 Bazooka'
 

Ugikie

Member
Joined
Jan 20, 2017
Messages
74
I am having trouble with using custom models for items. I added a model for a gun to a stone hoe, and when I spawn a zombie mob with the item it just shows the stone hoe instead of the weapon model. I know its set up right since crackshot can show the model just fine

heres how the item is set up

Code:
ZombieBazooka:
  Id: 291
  Data: 9
  Unbreakable: true
  Hides:
  - ATTRIBUTES
  - ENCHANTS
  Display: '&2M1 Bazooka'
Try putting Unbreakable inside Options like this:

Code:
ZombieBazooka:
  Id: 291
  Data: 9
  Options:
    Unbreakable: true
  Hides:
  - ATTRIBUTES
  - ENCHANTS
  Display: '&2M1 Bazooka'
 

Robotnikman

Member
Premium Supporter
Supporter
Joined
Mar 30, 2017
Messages
95
Try putting Unbreakable inside Options like this:

Code:
ZombieBazooka:
  Id: 291
  Data: 9
  Options:
    Unbreakable: true
  Hides:
  - ATTRIBUTES
  - ENCHANTS
  Display: '&2M1 Bazooka'

Thanks it works now!
 
Top