What's new

Manual related suggestions/requests/reports

zDrakon

Well-Known Member
Supporter
Quality Assurance
Joined
Jul 31, 2015
Messages
1,044
edited. ty for the confirmation
 

zDrakon

Well-Known Member
Supporter
Quality Assurance
Joined
Jul 31, 2015
Messages
1,044
Update

I've added download links to the compatible Lib's disguise and protocol Lib .jar files on the manual in the Disguises: add on section! Thank @jaylawl, @xikage, and me for puling in our jars together and putting it up on that file share site. If they somehow get deleted due to security reasons from that site's end, we'll work a way to upload the files another way!
 

Xexorian

New Member
Joined
Jul 22, 2015
Messages
10
Armor sets the amount of armor custom items have. not adds. Damage adds to the amount of damage an item has. not sets. The manual has this backwards and states that damage attributes set the damage of items, but it infact adds to weapons and tools, and only sets the damage of block/non-weapon/tool based items. It may even be 1+damage, and actually adding to the base value but I haven't tested this very specifically. Only with tools and swords.

Armor seems to set the amount, with armor being difficult to test %DR on now that we have Armor and Toughness scaling both factors dynamically, I have tested that it seems to 'set' the amount as higher custom values reduce more damage dynamically than lower values, for example, putting armor 1 on diamond armor seems to bypass it's default armor amount and toughness 'when worn on body' etc.

Not sure what's up with that. But that's how it works currently. (Please don't change it, just update the manual.)
 

zDrakon

Well-Known Member
Supporter
Quality Assurance
Joined
Jul 31, 2015
Messages
1,044
I've aksed ricky to update since i dont have time right now. Thanks for letting us know.
 

Rickyling

Community Manager
Community Manager
Supporter
Moderator
Quality Assurance
Joined
Jul 24, 2015
Messages
672
Armor sets the amount of armor custom items have. not adds. Damage adds to the amount of damage an item has. not sets. The manual has this backwards and states that damage attributes set the damage of items, but it infact adds to weapons and tools, and only sets the damage of block/non-weapon/tool based items. It may even be 1+damage, and actually adding to the base value but I haven't tested this very specifically. Only with tools and swords.

Armor seems to set the amount, with armor being difficult to test %DR on now that we have Armor and Toughness scaling both factors dynamically, I have tested that it seems to 'set' the amount as higher custom values reduce more damage dynamically than lower values, for example, putting armor 1 on diamond armor seems to bypass it's default armor amount and toughness 'when worn on body' etc.

Not sure what's up with that. But that's how it works currently. (Please don't change it, just update the manual.)
It could be something to do with the particular method that Xikage uses to set attributes, he might have used the additive operation rather than setting it. I'll ask.
 

HappierGore

New Member
Joined
Jul 17, 2017
Messages
4
Okay, I put the damage, and that this mob dont drop other things, but this is ignored, the damage is 12, but only give 3, and my custom drops don't are dropped, and this config, "PreventOtherDrops" It's ignored too
I need help soon, please,I have changed the versions from the oldest to the recent but it's the same problem, pleeeease, Before this did not happen, Only today it's happen :(
I am looking forward to your response.
It is my config, the problem is with all my mobs, but its an example
Carnage:
Type: ZOMBIE
Display: '&2Zombie Carnage'
Health: 20
Damage: 12
Equipment:
- Sombrero:4
Drops:
- ADN1
Options:
PreventOtherDrops: true
PreventRandomEquipment: true
Skills:
- skill{s=Consumir} ~onAttack 0.3
 

jose_95

New Member
Joined
Aug 11, 2017
Messages
14
Allow more mechanics to use placeholders. In this case, "Message" and "Velocity".

Tried to use
- message{m="%denizen_<util.random.int[-10].to[10]>%"} @PIR{r=30} - velocity{m=set;x=%denizen_<util.random.int[-10].to[10]>%;y=%denizen_<util.random.int[-10].to[10]>%;z=%denizen_<util.random.int[-10].to[10]>%} @target

Expected to get a random number from -10 to 10 on a message, got "%denizen_<util.random.int[-10].to[10]>%" on the message and velocity works the same as if I used "1" for X, Y and Z.
 

anthony_carra

New Member
Premium Supporter
Supporter
Joined
Nov 19, 2018
Messages
2
console error help me 1.14.4


could not create Vfs.Dir from url. ignoring the exception and continuing
io.lumine.xikage.mythicmobs.util.reflections.ReflectionsException: could not create Vfs.Dir from url, no matching UrlType was found [file:/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/ext/libatk-wrapper.so]
either use fromURL(final URL url, final List<UrlType> urlTypes) or use the static setDefaultURLTypes(final List<UrlType> urlTypes) or addDefaultURLTypes(UrlType urlType) with your specialized UrlType.
at io.lumine.xikage.mythicmobs.util.reflections.vfs.Vfs.fromURL(Vfs.java:109) ~[MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.util.reflections.vfs.Vfs.fromURL(Vfs.java:91) ~[MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.util.reflections.Reflections.scan(Reflections.java:240) ~[MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.util.reflections.Reflections.scan(Reflections.java:202) [MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.util.reflections.Reflections.<init>(Reflections.java:123) [MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.util.reflections.Reflections.<init>(Reflections.java:168) [MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.util.reflections.Reflections.<init>(Reflections.java:141) [MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.util.reflections.VersionCompliantReflections.<init>(VersionCompliantReflections.java:19) [MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.volatilecode.v1_14_R1.VolatileAIHandler_v1_14_R1.<init>(VolatileAIHandler_v1_14_R1.java:117) [MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.volatilecode.VolatileCodeEnabled_v1_14_R1.<init>(VolatileCodeEnabled_v1_14_R1.java:40) [MythicMobs-4.9.0.jar:?]
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_242]
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) [?:1.8.0_242]
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) [?:1.8.0_242]
at java.lang.reflect.Constructor.newInstance(Constructor.java:423) [?:1.8.0_242]
at io.lumine.xikage.mythicmobs.MythicMobs.getVolatileCodeHandler(MythicMobs.java:332) [MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.MythicMobs.enable(MythicMobs.java:140) [MythicMobs-4.9.0.jar:?]
at io.lumine.xikage.mythicmobs.utils.plugin.LuminePlugin.onEnable(LuminePlugin.java:49) [MythicMobs-4.9.0.jar:?]
at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) [minecraft_server.jar:git-Spigot-cbd1a1b-009d8af]
at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:352) [minecraft_server.jar:git-Spigot-cbd1a1b-009d8af]
at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:417) [minecraft_server.jar:git-Spigot-cbd1a1b-009d8af]
at org.bukkit.craftbukkit.v1_14_R1.CraftServer.enablePlugin(CraftServer.java:461) [minecraft_server.jar:git-Spigot-cbd1a1b-009d8af]
at org.bukkit.craftbukkit.v1_14_R1.CraftServer.enablePlugins(CraftServer.java:375) [minecraft_server.jar:git-Spigot-cbd1a1b-009d8af]
at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:449) [minecraft_server.jar:git-Spigot-cbd1a1b-009d8af]
at net.minecraft.server.v1_14_R1.DedicatedServer.init(DedicatedServer.java:266) [minecraft_server.jar:git-Spigot-cbd1a1b-009d8af]
at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:775) [minecraft_server.jar:git-Spigot-cbd1a1b-009d8af]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_242]
 

xDayByDAYX

New Member
Premium Supporter
Supporter
Joined
Nov 17, 2017
Messages
5
Enter a brief description of what is broken [MMOItems]Seriously Bugs!Right click basic attack weapon!

What version of Minecraft are you using?
1.14

What server jar are you using? Spigot

What is this a bug report for? Other

What version of the plugin are you using? MMOItems-5.5.3,MMOLib-1.2.4

Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
Excuse me,sorry to bother you, I found a bug with <mmoitem>
There have some few situation when we test the damage
Firstly, there have two type of basic attack mode from weapon : left click or right click
I set two of them both have skill and own skill damage

It seem like when I using <right click basic attack weapon> in offhand
their skill damage and the basic ability which setting in weapon will be stack

The situation still same even I set twohand option was true.

Example Configurations
example :
<sword A>(left click basic attack) and <bow B> (right click basic attack)
<sword A> skill damage:1
<bow B> skill damage :2

situation 1: (normal )
-I using two <sword A> in main hand and my offhand
-When I using my skill it take 1 damage

situation 2: (bug)
-I using <sword A> in main hand and using <bow b> with my offhand
-When I using skill(main hand) it will take 3 damage
-their skill damage was overlap

situation 3: (normal)
-I using two <sword A> in main hand and my offhand
-<sword A> was setting for +hp:10 when I equip
-My total hp was 30(basic 20)

situation 4: (bug)
-I using <sword A> in main hand and using <bow b> with my offhand
-<sword A> was setting for +hp:10 when I equip
-<bow b> was setting for +hp:20 when I equip
-My total hp was 50(basic 20)
 
Top