Bug: RP sounds audible worldwide

Discussion in 'Bug Reports' started by Tof, Feb 10, 2020.

  1. Tof

    Tof New Member

    Joined:
    Sep 17, 2017
    Messages:
    24
    Likes Received:
    0
    Enter a brief description of what is broken RP sounds audible worldwide

    What version of Minecraft are you using?
    1.13 R2

    What server jar are you using? Spigot

    What is this a bug report for? MythicMobs

    What version of the plugin are you using? 4.6.5

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    I added custom sounds to a resource pack. When I try to play those sounds, the sounds are audible in the whole world, just like thunder. I asked someone good with resource packs about this and they told me the following:

    "categories are deprecated.
    And it depends on how they are played.
    You can play master sounds, those are world wide.
    Or you can play them like normal sounds.
    I guess Mythicmobs might need some additional configuration to change that."

    So far the only options the "sound" mechanic has are 'sound', 'pitch', and 'volume'.

    I think we need the fourth option 'category'. So the custom sounds won't be played as a 'master' category all the time, which are worldwide.

    Though I'm not sure if adding this 'category' option would help at all, I'll write down the categories I'm talking about here:

    ambient
    block
    hostile
    master
    music
    neutral
    player
    record
    voice
    weather

    Note: I'm sure I don't make any typo mistakes, because when I switch the custom sound name with a vanilla sound, it plays as it's supposed to play - not worldwide

    Example Configurations
     
    #1
  2. jaylawl

    jaylawl Developer
    Developer Community Manager Premium Supporter Supporter Quality Assurance

    Joined:
    Sep 16, 2015
    Messages:
    1,835
    Likes Received:
    175
    the category option has been added to the upcoming 4.9 version, this is unlikely to affect your issue though.

    you propably messed up the resourcepack configuration of the sound effect you added. however its impossible to tell because you didnt post any related configs
     
    #2

Share This Page